Saturday, April 16, 2011

PyOpenGL and PyOpenGL-accelerate 3.0.1 - latest version

First , the major error is this:
I try fix this with ... NetFx20SP2_x86.exe, not working.
I use google to donload the dll file. Is not correct way , but this fix error.
I use this PyOpenGL-3.0.1.zip to install OpenGL module under Python 2.6.2 ...
Just use this :
python setup.py install
But you can not use python on command line, because you need to add on enviroment vars...
Just try something like this...
C:\>set PATH=C:\Python26;%PATH%
To see the result , just use:
C:\path
You can test the OpenGL modules...
>>> import OpenGL
>>> import OpenGL_accelerate
>>> help(OpenGL_accelerate)
Help on package OpenGL_accelerate:

NAME
    OpenGL_accelerate - Cython-coded accelerators for the PyOpenGL wrapper

FILE
    c:\python26\lib\site-packages\opengl_accelerate\__init__.py

DESCRIPTION
    This package contains Cython accelerator modules which
    attempt to speed up certain aspects of the PyOpenGL 3.x
    wrapper mechanism.  The source code is part of the
    PyOpenGL package and is built via the setupaccel.py
    script in the top level of the PyOpenGL source package.

PACKAGE CONTENTS
    arraydatatype
    errorchecker
    formathandler
    latebind
    nones_formathandler
    numpy_formathandler
    vbo
    wrapper
-- More  --
This is all .

No comments:

Post a Comment